• Welcome to this new upgrade of the site. We are now on a totally different software platform. Many things will be different, and bugs are expected. Certain areas (like downloads and reviews) will take longer to import. As always, please use the Meta Forum for site queries or bug reports. Note that we (the mods and admins) are also learning the new software.
  • The RSS feed for the news page has changed. Use this link. The old one displays the forums, not the news.

Dark Text on a Dark Background Tutorial

Morrus

Well, that was fun
Staff member
If you're reading this, the chances are you posted something in the forums and someone started telling you that they can't read it because you've used dark text on a dark background - and, with a little luck, they've been kind enough to post a link to this explanation for you.

Further, the odds are that you have no idea what they're talking about because you're using the white background. So, to avoid that "Can't read dark text on dark background"; "Huh? It looks fine to me?"; "Try switching style and having a look"; "What do you mean? I haven't added any colours!" etc. which totally derails your thread, I've put this little tutorial together.

Verify!


If someone tells you this has happened, you can quickly verify it. Use the style selector in the bottom left of every page and view your post in one of the dark skins ("Legacy" or "Eric Noah's Half Fiend Love Child" are good examples). Here's a picture of what the Style Selector look like:

style.jpg

You'll probably see that your post looks something like this:

1.png

What causes it?


The likelihood is that you copy/pasted your post from somewhere else. A word processor, or a post on another website, or something. Wherever that was, it had "black" encoded as the text colour rather than "default". "Black" makes it appear black wherever you post it, even if that location has a black background. "Default" makes it conform to the correct text colours for the location you're posting.

How do I get rid of it?


It's super-easy! All you need to do is select your text (edit your post, Ctrl-A to select the entire thing) and then click the following button in the post editor. It removes all formatting, and your post becomes legible! That's it!

textcleartute.jpg

I hope this helps. And if you see a post with this problem, the easiest thing to do is to simply link to this post rather than derail a thread with an attempt to explain!
 

Attachments

Last edited:

Dannyalcatraz

Moderator
Staff member
FYI, it looks like the "Legacy" option has disappeared from the menu. The only options I have are Reborn, Eric Noah, and Eric Noah's Half-Fiend Love Child. (FWIW, I'm viewing the full site on an iPad 2 without using Tapatalk.)
 

Illithidbix

Villager
Oh thank Bahamut, the forum is readable again.

I am going to pretend that this obviously wasn't me misclicking and spending several days being confused.
 

Advertisement

Top