D&D (2024) Backward Compatibility

shadowoflameth

Adventurer
It has been the statement of the Wizards people that all 5E material will be backward compatible with the new revision. Feats are an optional rule. I like them but if they are no longer optional and being rewritten and if level requirements that didn't exist before come into being, then that's not backward compatible. If it becomes optional to add a feat to a background I have no issue with that if legacy versions are allowed. i.e. if the new version omits an ability that you want to use, you still have the option to use the old way.
 

log in or register to remove this ad

UngainlyTitan

Legend
Supporter
It has been the statement of the Wizards people that all 5E material will be backward compatible with the new revision.
Well no, the FAQ on backward compatibility on D&D Beyond only states that current adventures and supplements will be included in the backwards compatibility. The Core 3 are not included. Now, what exactly that means remains to be seen since current supplements include feats.
Feats are an optional rule. I like them but if they are no longer optional and being rewritten and if level requirements that didn't exist before come into being, then that's not backward compatible. If it becomes optional to add a feat to a background I have no issue with that if legacy versions are allowed. i.e. if the new version omits an ability that you want to use, you still have the option to use the old way.
We could argue the that but everyone is likely to have their own lines as to what constitutes "Backward Compatibility". It remains to be seen as to what will happen to existing feats. My belief is that they will be tossed, and a replacement feat system will be created that will not be optional.
 

Iosue

Legend
It has been the statement of the Wizards people that all 5E material will be backward compatible with the new revision. Feats are an optional rule. I like them but if they are no longer optional and being rewritten and if level requirements that didn't exist before come into being, then that's not backward compatible. If it becomes optional to add a feat to a background I have no issue with that if legacy versions are allowed. i.e. if the new version omits an ability that you want to use, you still have the option to use the old way.
I was going to make a snarky comment about WotC putting out non-backwards compatible editions for so long that no one knows what backwards compatible even means any more. Then I realized that the 3.0 is 19 years old. Good grief.

First of all, Wizards has not said that "all 5e material will be backward compatible with the new revision." That actually doesn't even make sense. The edition will have to be backward compatible with the old material (backward = "going back"). What Wizards has said is that the new rules will be backward compatible with 5e "adventures and supplements." And all that means is that there will be enough rules overlap, and most important, the same essential PC vs monster math that you can run a 5e adventure with One D&D characters with a minimal amount of conversion work. Just like how you could run Keep on the Borderlands (Basic D&D) or Temple of Elemental Evil (AD&D) with AD&D 2nd Edition characters.

Conversely, you cannot run a 4e adventure with 5e unless you convert all the monsters and traps. You cannot run a 3e adventure with 4e unless you convert all the monsters and traps. You cannot run a 2e adventure with 3.x unless you at least convert all the monsters to ascending AC.

Backward compatibility has never been about seamlessly running previous edition characters alongside new edition characters. If that can happen, it's a huge bonus, but generally it can be expected that some conversion of the old characters to the new rules will be required.
 

from the FAQ of the One D&D test pages on D&D Beyond

My take on this (I just put up a video on YouTube on the it) is that the rules in the 2014 Player Handbook and DMG are not compatible with the corresponding 2024 books.
snip
So if you have a class built under the existing ruleset and were using feats you replace the feats with their new equivalents as per the new rules. The starting ASI have already been incorporated (for practical purposes) and you are good to go but the game is played under one or other rules set. You cannot play a hybrid 2014/2024 ruleset (at least not officially)
my thought has been for sometime that they mean DM backwards compatible... you can use the adventures. Not PC... you can't use class and feats without house rules
 

JiffyPopTart

Bree-Yark
With the recent playtest and the continued express commitment to backward compatibility on the 2024 rules release, by whatever name. I'm wondering if backward compatibility from One D&D back to 5E will truly work. The changes being tested seem to indicate not.

Grappling not using ability checks to grapple makes useless abilities, feats etc. that relate to those checks. (including for the Plasmoid published this past week).
Crits, you could always do the way you want but IMHO this playtest represents a less fun option, and where do I recycle my Adamantine Armor?
Backgrounds having feats. What if you already have that background but not that feat. Is your character still compatible? If backgrounds can be customized, then every background shouldn't need a feat, especially with feats having been an optional rule in 5E. what if you're the variant human with a feat that is no longer 1st level?
Why rewrite feats that players like? It raises the question, 'If I have Alert already and want to keep it, it my character still valid by the new PHB? Will legacy options be available? What about the half races? Same question. If I like my half orc character and like Relentless Endurance do I just lose it? What if my dwarf likes the existing stone-cunning? or if I want mountain Dwarves to be different from Hill Dwarves.
Does the wording on natural 20s and ones call out that some things are going to be impossible regardless of the roll. (and they should be).
I'm sure there are other things, but if backward compatibility is going to be anything other than a lie, we're going to need a lot of this very limited playtest to be revisited. i.e. Have grappling include things to do that will use an ability check, like pinning an opponent, let crit restrictions be optional or drop it. make customizable background options that don't include a feat or include an alternative benefit.
drop the level prerequisite or allow 1st level to trump the prerequisite.
drop the re-write of feats like alert or lucky and re-write ones that nobody takes, ever. I'm looking at you weaponmaster. Stop trying to fix the wrong problem and simply edit the PHB with changes that do not hurt backward compatibility. Start with options that no one uses; bad feats, useless spells, unplayable sub classes, features that players or DMs ignore now. That would boost sales of the new book(s) because fans have been hoping for those fixes in official rules for years.
Compatible is not the same as equal. If you can sit down at a 6e table with a 5e character sheet and play the game it's compatible. Character X having a feat that Character Y doesn't doesn't make it incompatible.

You might have an argument about imbalanced, sure, but that's a different topic.
 

UngainlyTitan

Legend
Supporter
snip

my thought has been for sometime that they mean DM backwards compatible... you can use the adventures. Not PC... you can't use class and feats without house rules
I am not saying you are wrong, but if you cannot use the classes and subclasses in books like Tasha's and Xanathar's , with at most minor tweaks, then it is not backwards compatible. At least not by the standard as stated in the FAQ.
 

SteveC

Doing the best imitation of myself
I would have no expectation for backwards compatibility in any but the most basic sense. I've been through every new edition since, well, the White Box, and backwards compatibility is something that always gets talked about. I don't think there's been a backwards compatible edition since 1E moved to 2E.
WotC wants to sell books for the next two years or whenever the new edition lands, so of course there is going to be discussion of it. Will it happen? I would not count on it.
 

It has been the statement of the Wizards people that all 5E material will be backward compatible with the new revision. Feats are an optional rule. I like them but if they are no longer optional and being rewritten and if level requirements that didn't exist before come into being, then that's not backward compatible. If it becomes optional to add a feat to a background I have no issue with that if legacy versions are allowed. i.e. if the new version omits an ability that you want to use, you still have the option to use the old way.
If you don't want your character to have feats then they can just take the repeatable Ability Score Improvement 4th level feat. And there's nothing preventing the old backgrounds working - so you never need to take a non-ASI feat regardless of which version you are using. So the legacy versions still work.

The question is about the legacy versions of the current feats. But that's mostly errata.
 


Bard just got a complete rewrite... and there isn't a good way to combine them with 2014 bard. I wonder what excuse this will be given for back compatibility.

You even get subclass level changes and a whole subclass feature level got added
 

Voidrunner's Codex

Remove ads

Top