D&D General Anyone else experiencing formatting issues with the WotC D&D Surveys


A Title Much Cooler Than Anything on the Old Site
I just completed the latest WotC D&D survey. Not the 1D&D playtests, but the general survey where they ask you when you first started playing, how much you spent in the last 6 months, etc.

Aaaand just like the last two time, the format was a mess. The save button is HUGE taking the entire width of the browser window and you have to scroll quite a bit to get to the text of the question on the page you are on. Also, the save button doesn't work. Not that big of an issue because I complete the surveys in one sitting.

Also, there is a question about how recently you played ANY edition of D&D OTHER THAN 5e. I selected an answer that was longer than a year ago (forgot exact wording). Then the next page had two questions. Why didn't you play D&D for over a year and what would you need to play D&D again. I kept going back to prior pages to see if I missed a question or mis-answered one. Nope. So either they botched their survey design or it didn't load/display a question.

There was another question where you needed to order things in order of preference by drag-and-drop, but it was just displayed as a text list for me and I could not reorder them, so I just skipped that question.

I was still able to answer most questions and complete the survey, but it is driving me nuts. I tried loading the survey on three different browsers: Edge, Firefox, and Chrome. I tried incognito and in-private windows. I made sure no add blockers or script blockers were running. I tried changing my settings to the lowest level of protection or turn protection off and each of the browsers.

Nothing worked.

I'm filling out and creating surveys all the time. No issues with Survey Monkey. No issues with MS O365/Teams surveys. No issues with order forms. No issues with any other websites. Just these stupid WotC forms and each of the last three surveys over the past one or two years have been like this.

Anyone else seeing this? Any thoughts on what might be causing this?

log in or register to remove this ad

Remove ads