4E Get WotC 4e's Online Character Builder to work or get a sub

MwaO

Explorer
Hi guys ,Like most of you l 've used the CB and the AB for years and now l'm having problems .Every time l try to use them l have to install silverlight ,l do this but then a message appears stating that lt is impossible because l alerady have this program.
Can you help me? thank you
You likely have a mac that upgraded into making safari not work with it any longer. Try using sea monkey browser(basically mozilla took the old firefox and is updating it) listed in the link on the first page.

I basically just use sea monkey for that exact one specific purpose.
 

MwaO

Explorer
It works for me. I'd really try to use the Sea Monkey browser if you haven't already done so. It really is the best option by far for stability.
 

MwaO

Explorer
I already have a sub, but it gets me to the page where I'd hand them money again. You might need to make a new account even if you had an old one. If you had an old one, you might need to email WotC custserv to relink them, but not sure how that goes. If anyone needed to do it, please post here as to the how, and I'll put it in the initial post.
 

Nemesis Destiny

Adventurer
I'd be interested to know, since I'm considering subbing with my own account instead of our group's shared one, just to keep the magic alive.
 
Just sent a message to the dnd support for ddi orders with this message, I'll let you know how it goes :

Hello,

I know the DDI tool for 4e isn't supported anymore, but according to forums it's still working.
I'd like to purchase a ddi access, and I've arrived on this page : http://gc.digitalriver.com/store/dndi/html/pbPage.wizards which seems the page to get or renew a ddi subscription.

However, in the process of buying the subscription, I arrive on a page where I have to enter my wizard account login and password. When I do so, the store bugs with a 504 error (too long to respond). People in forums told me it was working for them, but they already had subscription prior to the discontinuation of the ddi tools. I assume there was some kind of process allowing the ddi store to link to the wizard account, and that's probably what is not working anymore.

Is there by chance a way to get this to work with my account? I assume the support teams mainly moved to D&D5 products by now, but if a kind soul with knowledge of the 4e ddi could help me, I would be immensely grateful.

Thanks a lot,
Edit : first answer from support "try with another browser, clear cache, it should work" (with a nicer tone ;-) ). I've tried 4 different browsers, it didn't. I updated the ticket with the steps I did.

Edit 2 : several "have you tried another devices" steps later, still no change, but the support answers quite fast.

Edit 3 : ticket escalated to another team after a week. Wait & see.

Edit 4 : after a lot of back & forth, seems the ddi subscription link on digital river is working again. I don't know if my email had anything to do with it, but it works! ;)
 
Last edited:

MwaO

Explorer
Seeing both online compendium and character builder down. Everyone else seeing the same thing? If you do, note the link in the first post to submit a request to fix...
 

Nemesis Destiny

Adventurer
Yes, I checked to see if it was just you. I'm using IE11.

Mine loaded to 97%, then stalled. A few moments later, I got a prompt that Silverlight had an update and did I want said update. I hit 'yes' and nothing happened, but I got the little 'this page is having problems' bar at the bottom, and asked if I wanted to recover. I hit yes. Page reloaded but asked me if I wanted to display 'mixed content.' I again hit 'yes' and everything loaded in as it should.

I closed all open IE windows (which is just this app, because this and power2ool.com is the only thing I use IE for), and relogged in. This time, just got a white screen, and when I clicked on it, got the 'page is having problems' and 'run mixed content?' dialogs, but it still loads in after this. Character portraits are all blank, but the app is working.
 

MwaO

Explorer
Yes, I checked to see if it was just you. I'm using IE11.

Mine loaded to 97%, then stalled. A few moments later, I got a prompt that Silverlight had an update and did I want said update. I hit 'yes' and nothing happened, but I got the little 'this page is having problems' bar at the bottom, and asked if I wanted to recover. I hit yes. Page reloaded but asked me if I wanted to display 'mixed content.' I again hit 'yes' and everything loaded in as it should.

I closed all open IE windows (which is just this app, because this and power2ool.com is the only thing I use IE for), and relogged in. This time, just got a white screen, and when I clicked on it, got the 'page is having problems' and 'run mixed content?' dialogs, but it still loads in after this. Character portraits are all blank, but the app is working.
Yeah, right after I hit send to tech support, it started working again. Weird.
 

Scoops

Visitor
Just sent a message to the dnd support for ddi orders with this message, I'll let you know how it goes :






Edit : first answer from support "try with another browser, clear cache, it should work" (with a nicer tone ;-) ). I've tried 4 different browsers, it didn't. I updated the ticket with the steps I did.


Edit 2 : several "have you tried another devices" steps later, still no change, but the support answers quite fast.


Edit 3 : ticket escalated to another team after a week. Wait & see.


Edit 4 : after a lot of back & forth, seems the ddi subscription link on digital river is working again. I don't know if my email had anything to do with it, but it works! ;)
I'm getting the 504 error too, and support is giving me the same run around. How did you get them to escalate the ticket and which ticket subject option did you use?
 
Last edited:

MwaO

Explorer
I'm getting the 504 error too, and support is giving me the same run around. How did you get them to escalate the ticket and which ticket subject option did you use?
I'd either ask them to relink your old account(because they changed accounts at some point after the forums died) or just make a new account.

I think that's a lot easier, especially if as an example, you're just using Sea Monkey's browser for just DDI. Then you don't have to worry about changing logins on your usual browser.

I'm not sure if that works(because no one has told me if that's what they did and I already have an account...), but I think that should be a lot easier.
 

Scoops

Visitor
I'd either ask them to relink your old account(because they changed accounts at some point after the forums died) or just make a new account.

I think that's a lot easier, especially if as an example, you're just using Sea Monkey's browser for just DDI. Then you don't have to worry about changing logins on your usual browser.

I'm not sure if that works(because no one has told me if that's what they did and I already have an account...), but I think that should be a lot easier.
I tried making a new account, the same thing happens: whenever I go to purchase a subscription and it asks me to log in again for confirmation, hitting the log in button just times out. For reference, on my old account, I had a subscription as recently as August 2018.
 

Advertisement

Top