What's the deal with the text editor?

Frankie1969

Explorer
The following bug is 100% reproducible for me:
  1. write a multi-line post (either new or reply).
  2. go back and do any kind of formatting on a line that isn't the last.
  3. the formatting correctly affects the selected text.
  4. the formatting doesn't affect the following line.
  5. the formatting incorrectly affects all of the text from the 2nd line down to the end of the post.
  6. do some more formatting. sometimes it affects the other lines, sometimes it doesn't.
  7. edit a later line. sometimes the incorrect formatting goes away.
See?
 

Umbran

Mod Squad
Staff member
Yep. Let me guess - you are using Firefox as a browser?

What you are describing is a known bug in Firefox that we, unfortunately, can't fix on our end.
 

Umbran

Mod Squad
Staff member
What I think you're saying is "we choose not to fix this because Firefox isn't following the spec".
No. I am saying that EN World is not a software development shop.

We do not write code. We do not have someone on staff with the skills to hack up the text editor to make up for Firefox not following the spec.
 

Len

Prodigal Member
I don't think Frankie is asking you to fix it (he did say "Fair enough"), he's asking where the bug is reported so that we can go and add our requests to the Firefox developers to get it fixed. I'd like to know that too.
 

Umbran

Mod Squad
Staff member
I don't think Frankie is asking you to fix it ....
He explicitly said he thought it was about how we CHOOSE not to fix it, like we don't prioritize user requests, or something. If we had the resources to create, test, and maintain customizations, I don't doubt it would happen. But, we don't. So it isn't really our choice.

And no, I don't know the bug numbers either for Firefox or Xenforo.
 

Frankie1969

Explorer
@Umbran I apologize. You're right, "don't have the resources" is a legitimate meaning of "can't".

Bug List: Xenforo returns two bugs, neither of which sound like this one. If you or someone else at EnWorld could post what you know about it, I'll try to get someone to work on it.
 

Frankie1969

Explorer
Further investigation: the bug is in Froala editor v2.9.6 used by Xenforo v2.1.3.
Xenforo 2.1.4 (latest) downgrades Froala to 2.9.5, which fixes it.
Meanwhile, Froala is working on 2.9.7, which will also fix it.
 
  • Like
Reactions: Len

Sacrosanct

Legend
I’m using chrome on my iPad and have almost the same issues. Hitting return tweet times is needed to go to a new line, which doesn’t automatically capitalize the first letter, and if I quote someone, no matter how many times I click at the bottom to add text, it puts the text in the middle of the quoted message. Super annoying. And makes it look like I have fifth grade grammar skills lol.
 

Morrus

Well, that was fun
Staff member
I’m using chrome on my iPad and have almost the same issues. Hitting return tweet times is needed to go to a new line, which doesn’t automatically capitalize the first letter, and if I quote someone, no matter how many times I click at the bottom to add text, it puts the text in the middle of the quoted message. Super annoying. And makes it look like I have fifth grade grammar skills lol.
Those are not the same issues. That's something entirely different.
 

Frankie1969

Explorer
Testing the XF editor in FF.
Here's another line. And now I go back to edit and reformat this line.
It takes at least three to trigger the error.
So let's put a 4th just to be sure, then go back.

Yes, XF is working correctly in Firefox now. Thanks!
 

Frankie1969

Explorer
@Sacrosanct auto-capitalization isn't a feature of the editor. That must come from something else on your iPad. I'm guessing you have a 3rd party keyboard app, or malware. But in any case, you should post about that in another thread.
 

Morrus

Well, that was fun
Staff member
Yeah. Xenforo doesn't autocapitalise or autocorrect anything for you. iPads do.
 

Sacrosanct

Legend
Those are not the same issues. That's something entirely different.
im sorry, I meant I get many of the same issues PLUS the ones I mentioned

and I wasn’t blaming anyone particular, just that I only have those issues on this forum and nowhere else, so it’s odd if it were an iPad issue that that would be the case
 

Lanefan

Victoria Rules
The Firefox-vs-Xenforo text editing issues seem to have gone away as of today for me at least, so thank you to whoever was responsible for the fix! :)
 

Morrus

Well, that was fun
Staff member
You don’t need to quote me from another thread. I said that in post #9 of this thread.
 

Advertisement

Top